Your host needs to use PHP 5.5.20 or higher to run this version of Joomla!